<!DOCTYPE html>
<html>
  <head>
    
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
        <meta name="viewport" content="width=device-width, initial-scale=1">

        <link rel="shortcut icon" href="/static/img/favicon.ico" />
        <title>RHEL8: Adding a second drive to LVM - James</title>
        <meta name="author" content="James J" />
        <meta name="description" content="RHEL8: Adding a second drive to LVM" />
        <meta name="keywords" content="RHEL8: Adding a second drive to LVM, James, linux" />

        <meta content="0" property="fb:app_id">
        <meta content="James" property="og:site_name">
        
          <meta content="RHEL8: Adding a second drive to LVM" property="og:title">
        
        
          <meta content="article" property="og:type">
        
        
          <meta content="My piece of the Internet." property="og:description">
        
        
          <meta content="/linux/2019/10/09/rhel8-adding-a-drive-to-lvm.html" property="og:url">
        
        
          <meta content="2019-10-09T07:43:00-04:00" property="article:published_time">
          <meta content="/about/" property="article:author">
        
        
          <meta content="/static/img/logo-high-resolution.png" property="og:image">
        
        
          
          <meta content="linux" property="article:section">
          
        
        
          
        
        <meta name="twitter:card" content="summary">
        <meta name="twitter:site" content="@\#">
        <meta name="twitter:creator" content="@\#">
        
          <meta name="twitter:title" content="RHEL8: Adding a second drive to LVM">
        
        
          <meta name="twitter:url" content="/linux/2019/10/09/rhel8-adding-a-drive-to-lvm.html">
        
        
          <meta name="twitter:description" content="My piece of the Internet.">
        
        

      <link rel="alternate" type="application/rss+xml" title="RSS" href="/feed.xml">
      <script type="text/javascript">window.baseurl = '';</script>
      
        <!-- Custom Fonts -->
        <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:300,400,500,700" type="text/css">

        <!-- FontAwesome icons -->
        <link rel="stylesheet" href="https://use.fontawesome.com/74dfc6cf47.css">

        <!-- Core BootStrap CSS -->
       <link rel="stylesheet" href="/static/css/bootstrap.min.css">
        <!-- Material Design CSS -->
        <link rel="stylesheet" href="/static/css/bootstrap-material-design.min.css">

        <!-- syntax highlighting CSS -->
        <link rel="stylesheet" href="/static/css/syntax.css">

        <!-- Custom CSS -->        
        <link rel="stylesheet" href="/static/css/thickbox.css">
        <link rel="stylesheet" href="/static/css/main.css">
        <link rel="stylesheet" href="/static/css/projects.css">

        <script type="text/javascript">
          //loadingImage is relative to project dir
          var tb_pathToImage = "/static/img/loadingAnimation.gif";
        </script>
<script data-ad-client="ca-pub-1257534224610502" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

  </head>

  <body class="home overflow-hidden">
    <div class="header-panel shadow-z-2">
      <div class="container">
        <div class="row">
          <div class="col-md-3 col-sm-4 col-xs-12">
            <div class="row-picture">
              <img id="about" class="logo-img" src="/static/img/avatar.png" height="75px" width="75px">
            </div>
            <div class="row-details">
              <h4 class="list-group-item-heading">James J</h4>
              <p class="list-group-item-text">Sysadmin/Engineer/Developer</p>
              <div class="social-icons">
	
        <a class="icon" target="_blank" href=""><i class="fa fa-facebook"></i></a>
    
        <a class="icon" target="_blank" href=""><i class="fa fa-twitter"></i></a>
    
        <a class="icon" target="_blank" href=""><i class="fa fa-linkedin"></i></a>
    
        <a class="icon" target="_blank" href=""><i class="fa fa-stack-exchange"></i></a>
    
</div>

            </div>
            <div class="navbar-header pull-right">
              <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1" aria-expanded="false">
                <span class="sr-only">Toggle navigation</span>
                <i class="fa fa-2x fa-bars"></i>
              </button>
            </div>
          </div>
          <div class="col-md-9 col-sm-8 col-xs-12">
          <div class="row">
            <h2 class="blog-title-pro col-md-6 col-sm-12 col-xs-12 ">RHEL8: Adding a second drive to LVM</h2>
            
            <div class="col-md-6 col-sm-12 col-xs-12 searchcontrol" id="js-search">
              <input class="form-control" type="text" id="js-search__input" placeholder="Search">
              <ul class="search__results" id="js-search__results"></ul>
            </div>
            
            </div>
            <p class="info">
              
                <span class="time">09 Oct 2019</span>
              
              
                <span class="categories">
                  &raquo; 
                  
                    <a href="/category/linux.html">linux</a>
                    
                  
                </span>
              
            </p>
          </div>
        </div>
      </div>
    </div>

    <div class="container main outer">
      <div class="row">
        <div class="col-md-3 col-xs-12">
              <nav class="menu">
    <div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
    <ul class="list-separator nav navbar-nav well well-primary post">

	
	
	
	
	
	
    
	
	<li class="col-lg-12 col-md-12 col-sm-4 col-xs-12 current-menu-item rhel8-adding-a-drive-to-lvm.html"><a href="/" target="_self"><i class="fa fa-home"></i> Home</a></li>

	
	
	
	
	
	
    
	
	<li class="col-lg-12 col-md-12 col-sm-4 col-xs-12  rhel8-adding-a-drive-to-lvm.html"><a href="/projects" target="_self"><i class="fa fa-desktop"></i> Projects</a></li>

	
	
	
	
	
	
    
	
	<li class="col-lg-12 col-md-12 col-sm-4 col-xs-12  rhel8-adding-a-drive-to-lvm.html"><a href="/category/instagram.html" target="_self"><i class="fa fa-instagram"></i> Instagram</a></li>

	
	
	
	
	
	
    
	
	<li class="col-lg-12 col-md-12 col-sm-4 col-xs-12  rhel8-adding-a-drive-to-lvm.html"><a href="/about/" target="_self"><i class="fa fa-comments"></i> About</a></li>

	
	
	
	
	
	
    
	
	<li class="col-lg-12 col-md-12 col-sm-4 col-xs-12  rhel8-adding-a-drive-to-lvm.html"><a href="https://github.com/jayninja" target="_self"><i class="fa fa-github"></i> Github</a></li>

	
	
	
	
	
	
    
	
	<li class="col-lg-12 col-md-12 col-sm-4 col-xs-12  rhel8-adding-a-drive-to-lvm.html"><a href="/feed.xml" target="_blank"><i class="fa fa-feed"></i> XML Feed</a></li>

</ul>

    </div>
    </nav>

        </div>
        <div class="col-md-9 col-xs-12 full">
          <!-- Look the author details up from the site config. -->


<!-- Output author details if some exist. -->

<div class="post-content well">
<article class="content">
    <div class="post"><ul id="markdown-toc">
  <li><a href="#description" id="markdown-toc-description">Description</a></li>
  <li><a href="#partition" id="markdown-toc-partition">Partition</a>    <ul>
      <li><a href="#add-a-partition" id="markdown-toc-add-a-partition">Add a partition</a></li>
      <li><a href="#tag-the-partition" id="markdown-toc-tag-the-partition">Tag the partition</a></li>
    </ul>
  </li>
  <li><a href="#lvm" id="markdown-toc-lvm">LVM</a>    <ul>
      <li><a href="#add-pv-to-vg" id="markdown-toc-add-pv-to-vg">Add PV to VG</a></li>
      <li><a href="#create-a-new-logical-volumelv" id="markdown-toc-create-a-new-logical-volumelv">Create a new Logical Volume(LV)</a></li>
      <li><a href="#extend-an-existing-logical-volumelv" id="markdown-toc-extend-an-existing-logical-volumelv">Extend an existing Logical Volume(LV)</a></li>
    </ul>
  </li>
  <li><a href="#conclusion" id="markdown-toc-conclusion">Conclusion</a></li>
</ul>
<p> </p>

<h2 id="description">Description</h2>

<p>We have all been in the situation where we ran out of space, and need to add another drive. Back before LVM, you would have to add a second drive, create a partition, and find a decent place to mount it. For example /var/lib/mysql. Not only do you have to get the new drive ready, but then you have to shut things down and copy the data to the secondary. Then update fstab, so it survives reboots. You will be happy to hear those days are over. It is a bit more complicated, but the space is just magically available for LVM to put wherever you need it.</p>

<p>In this example, I am using VMware. I provisioned a RHEL8 VM with a single 20GB disk. Once it was installed, I added a second 20GB disk.<br />
 </p>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 ~]# fdisk -l | grep <span class="s2">"Disk /dev/sd"</span>
Disk /dev/sda: 20 GiB, 21474836480 bytes, 41943040 sectors
Disk /dev/sdb: 20 GiB, 21474836480 bytes, 41943040 sectors
<span class="o">[</span>root@rhel8 ~]#
</code></pre>
</div>
<p>/dev/sda is the disk that is currently holding my OS. /dev/sdb is the new disk.<br />
 </p>

<h2 id="partition">Partition</h2>
<h3 id="add-a-partition">Add a partition</h3>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 ~]# fdisk /dev/sdb

Welcome to fdisk <span class="o">(</span>util-linux 2.32.1<span class="o">)</span>.
Changes will remain <span class="k">in </span>memory only, <span class="k">until </span>you decide to write them.
Be careful before using the write command.

Device does not contain a recognized partition table.
Created a new DOS disklabel with disk identifier 0x53fe0e1f.

Command <span class="o">(</span>m <span class="k">for </span><span class="nb">help</span><span class="o">)</span>: n
Partition <span class="nb">type
   </span>p   primary <span class="o">(</span>0 primary, 0 extended, 4 free<span class="o">)</span>
   e   extended <span class="o">(</span>container <span class="k">for </span>logical partitions<span class="o">)</span>
Select <span class="o">(</span>default p<span class="o">)</span>: p
Partition number <span class="o">(</span>1-4, default 1<span class="o">)</span>: 1
First sector <span class="o">(</span>2048-41943039, default 2048<span class="o">)</span>:
Last sector, +sectors or +size<span class="o">{</span>K,M,G,T,P<span class="o">}</span> <span class="o">(</span>2048-41943039, default 41943039<span class="o">)</span>:

Created a new partition 1 of <span class="nb">type</span> <span class="s1">'Linux'</span> and of size 20 GiB.

Command <span class="o">(</span>m <span class="k">for </span><span class="nb">help</span><span class="o">)</span>: p
Disk /dev/sdb: 20 GiB, 21474836480 bytes, 41943040 sectors
Units: sectors of 1 <span class="k">*</span> 512 <span class="o">=</span> 512 bytes
Sector size <span class="o">(</span>logical/physical<span class="o">)</span>: 512 bytes / 512 bytes
I/O size <span class="o">(</span>minimum/optimal<span class="o">)</span>: 512 bytes / 512 bytes
Disklabel <span class="nb">type</span>: dos
Disk identifier: 0x53fe0e1f

Device     Boot Start      End  Sectors Size Id Type
/dev/sdb1        2048 41943039 41940992  20G 83 Linux

Command <span class="o">(</span>m <span class="k">for </span><span class="nb">help</span><span class="o">)</span>: w
The partition table has been altered.
Calling ioctl<span class="o">()</span> to re-read partition table.
Syncing disks.

<span class="o">[</span>root@rhel8 ~]#
</code></pre>
</div>

<p>Above, we created a new partition on /dev/sdb. The new partition will be /dev/sdb1, since it is the first partition. In any of the fields where I didnt enter something, we went with the default. Default is to take up the entire disk. Now that we have a new partition, we need to tag it as an LVM partition(id 8e), since it is currently a Linux partition(id 83).<br />
 </p>

<h3 id="tag-the-partition">Tag the partition</h3>

<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 ~]# fdisk /dev/sdb

Welcome to fdisk <span class="o">(</span>util-linux 2.32.1<span class="o">)</span>.
Changes will remain <span class="k">in </span>memory only, <span class="k">until </span>you decide to write them.
Be careful before using the write command.


Command <span class="o">(</span>m <span class="k">for </span><span class="nb">help</span><span class="o">)</span>: t
Selected partition 1
Hex code <span class="o">(</span><span class="nb">type </span>L to list all codes<span class="o">)</span>: 8e
Changed <span class="nb">type </span>of partition <span class="s1">'Linux'</span> to <span class="s1">'Linux LVM'</span>.

Command <span class="o">(</span>m <span class="k">for </span><span class="nb">help</span><span class="o">)</span>: w
The partition table has been altered.
Calling ioctl<span class="o">()</span> to re-read partition table.
Syncing disks.

<span class="o">[</span>root@rhel8 ~]# fdisk -l /dev/sdb
Disk /dev/sdb: 20 GiB, 21474836480 bytes, 41943040 sectors
Units: sectors of 1 <span class="k">*</span> 512 <span class="o">=</span> 512 bytes
Sector size <span class="o">(</span>logical/physical<span class="o">)</span>: 512 bytes / 512 bytes
I/O size <span class="o">(</span>minimum/optimal<span class="o">)</span>: 512 bytes / 512 bytes
Disklabel <span class="nb">type</span>: dos
Disk identifier: 0x53fe0e1f

Device     Boot Start      End  Sectors Size Id Type
/dev/sdb1        2048 41943039 41940992  20G 8e Linux LVM
<span class="o">[</span>root@rhel8 ~]#
</code></pre>
</div>

<p>As you can see above, our partition is created, and tagged as LVM. The tag honestly doesnt do anything other than letting other programs and people know what it is for. It is good practice to properly partiton and label things, even in the cloud.</p>

<p>Now that our partition is setup properly, lets move on to LVM.<br />
 </p>

<h2 id="lvm">LVM</h2>
<h3 id="add-pv-to-vg">Add PV to VG</h3>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 ~]# pvcreate /dev/sdb1
  Physical volume <span class="s2">"/dev/sdb1"</span> successfully created.
<span class="o">[</span>root@rhel8 ~]# vgs
  VG         <span class="c">#PV #LV #SN Attr   VSize   VFree</span>
  rhel_rhel8   1   2   0 wz--n- &lt;19.00g    0
<span class="o">[</span>root@rhel8 ~]# pvs
  PV         VG         Fmt  Attr PSize   PFree
  /dev/sda2  rhel_rhel8 lvm2 a--  &lt;19.00g      0
  /dev/sdb1             lvm2 ---  &lt;20.00g &lt;20.00g
<span class="o">[</span>root@rhel8 ~]# vgextend rhel_rhel8 /dev/sdb1
  Volume group <span class="s2">"rhel_rhel8"</span> successfully extended
<span class="o">[</span>root@rhel8 ~]# vgs
  VG         <span class="c">#PV #LV #SN Attr   VSize  VFree</span>
  rhel_rhel8   2   2   0 wz--n- 38.99g &lt;20.00g
<span class="o">[</span>root@rhel8 ~]#
</code></pre>
</div>

<p>First, we have to “create” the physical volume(PV). So we pvcreate it, and show the space available. Then we vgextended the “rhel_rhel8” volume group(VG) to assign the PV to it. So now we see the volume group has 20G free.<br />
 </p>

<h3 id="create-a-new-logical-volumelv">Create a new Logical Volume(LV)</h3>

<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 ~]# vgs
  VG         <span class="c">#PV #LV #SN Attr   VSize  VFree</span>
  rhel_rhel8   2   2   0 wz--n- 38.99g &lt;20.00g
<span class="o">[</span>root@rhel8 ~]# lvs
  LV   VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  root rhel_rhel8 -wi-ao---- &lt;17.00g
  swap rhel_rhel8 -wi-ao----   2.00g
<span class="o">[</span>root@rhel8 ~]#
</code></pre>
</div>

<p>As you can see the VG shows 20GB free. Lets create a new 1G volume, write an xfs file system to it, and mount it as /1gig_lv.<br />
 </p>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 ~]# lvcreate -L 1G -n 1gig_lv rhel_rhel8
  Logical volume <span class="s2">"1gig_lv"</span> created.
<span class="o">[</span>root@rhel8 ~]# lvs
  LV      VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  1gig_lv rhel_rhel8 -wi-a-----   1.00g
  root    rhel_rhel8 -wi-ao---- &lt;17.00g
  swap    rhel_rhel8 -wi-ao----   2.00g
<span class="o">[</span>root@rhel8 ~]# mkfs.xfs /dev/mapper/rhel_rhel8-1gig_lv
meta-data<span class="o">=</span>/dev/mapper/rhel_rhel8-1gig_lv <span class="nv">isize</span><span class="o">=</span>512    <span class="nv">agcount</span><span class="o">=</span>4, <span class="nv">agsize</span><span class="o">=</span>65536 blks
         <span class="o">=</span>                       <span class="nv">sectsz</span><span class="o">=</span>512   <span class="nv">attr</span><span class="o">=</span>2, <span class="nv">projid32bit</span><span class="o">=</span>1
         <span class="o">=</span>                       <span class="nv">crc</span><span class="o">=</span>1        <span class="nv">finobt</span><span class="o">=</span>1, <span class="nv">sparse</span><span class="o">=</span>1, <span class="nv">rmapbt</span><span class="o">=</span>0
         <span class="o">=</span>                       <span class="nv">reflink</span><span class="o">=</span>1
data     <span class="o">=</span>                       <span class="nv">bsize</span><span class="o">=</span>4096   <span class="nv">blocks</span><span class="o">=</span>262144, <span class="nv">imaxpct</span><span class="o">=</span>25
         <span class="o">=</span>                       <span class="nv">sunit</span><span class="o">=</span>0      <span class="nv">swidth</span><span class="o">=</span>0 blks
naming   <span class="o">=</span>version 2              <span class="nv">bsize</span><span class="o">=</span>4096   ascii-ci<span class="o">=</span>0, <span class="nv">ftype</span><span class="o">=</span>1
log      <span class="o">=</span>internal log           <span class="nv">bsize</span><span class="o">=</span>4096   <span class="nv">blocks</span><span class="o">=</span>2560, <span class="nv">version</span><span class="o">=</span>2
         <span class="o">=</span>                       <span class="nv">sectsz</span><span class="o">=</span>512   <span class="nv">sunit</span><span class="o">=</span>0 blks, lazy-count<span class="o">=</span>1
realtime <span class="o">=</span>none                   <span class="nv">extsz</span><span class="o">=</span>4096   <span class="nv">blocks</span><span class="o">=</span>0, <span class="nv">rtextents</span><span class="o">=</span>0
<span class="o">[</span>root@rhel8 ~]# mkdir /1gig_lv
<span class="o">[</span>root@rhel8 ~]# mount /dev/mapper/rhel_rhel8-1gig_lv /1gig_lv/
<span class="o">[</span>root@rhel8 ~]# <span class="nb">cd</span> /1gig_lv/
<span class="o">[</span>root@rhel8 1gig_lv]# ls -l
total 0
<span class="o">[</span>root@rhel8 1gig_lv]# touch <span class="nb">test</span>
<span class="o">[</span>root@rhel8 1gig_lv]# mount -l | grep 1gig
/dev/mapper/rhel_rhel8-1gig_lv on /1gig_lv <span class="nb">type </span>xfs <span class="o">(</span>rw,relatime,seclabel,attr2,inode64,noquota<span class="o">)</span>
<span class="o">[</span>root@rhel8 1gig_lv]#
</code></pre>
</div>

<p>The syntax of the lvcreate command could be a bit better. We used lvcreate to create a 1G volume, and we named it 1gig_lv, in the rhel_rhel8 volume group. We then used mkfs.xfs to write a brand new xfs file system to that LV. Now that it has a file system, it is mountable. So we mounted it on /1gig_lv. If you want this to be permanent, you need to make sure to add it to /etc/fstab. For this, I would add <code class="highlighter-rouge">/dev/mapper/rhel_rhel8-1gig_lv /1gig_lv                       xfs     defaults        0 0</code>.<br />
 </p>

<h3 id="extend-an-existing-logical-volumelv">Extend an existing Logical Volume(LV)</h3>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 1gig_lv]# vgs
  VG         <span class="c">#PV #LV #SN Attr   VSize  VFree</span>
  rhel_rhel8   2   3   0 wz--n- 38.99g &lt;19.00g
<span class="o">[</span>root@rhel8 1gig_lv]# lvs
  LV      VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  1gig_lv rhel_rhel8 -wi-ao----   1.00g
  root    rhel_rhel8 -wi-ao---- &lt;17.00g
  swap    rhel_rhel8 -wi-ao----   2.00g
<span class="o">[</span>root@rhel8 1gig_lv]#
</code></pre>
</div>

<p>Above is our current pvs/vgs/lvs after the last exercise. Lets say now we want to extend our root LV by 1G.<br />
 </p>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code>
<span class="o">[</span>root@rhel8 1gig_lv]# lvextend -L +1G /dev/mapper/rhel_rhel8-root
  Size of logical volume rhel_rhel8/root changed from &lt;17.00 GiB <span class="o">(</span>4351 extents<span class="o">)</span> to &lt;18.00 GiB <span class="o">(</span>4607 extents<span class="o">)</span>.
  Logical volume rhel_rhel8/root successfully resized.
<span class="o">[</span>root@rhel8 1gig_lv]# xfs_growfs /
meta-data<span class="o">=</span>/dev/mapper/rhel_rhel8-root <span class="nv">isize</span><span class="o">=</span>512    <span class="nv">agcount</span><span class="o">=</span>4, <span class="nv">agsize</span><span class="o">=</span>1113856 blks
         <span class="o">=</span>                       <span class="nv">sectsz</span><span class="o">=</span>512   <span class="nv">attr</span><span class="o">=</span>2, <span class="nv">projid32bit</span><span class="o">=</span>1
         <span class="o">=</span>                       <span class="nv">crc</span><span class="o">=</span>1        <span class="nv">finobt</span><span class="o">=</span>1, <span class="nv">sparse</span><span class="o">=</span>1, <span class="nv">rmapbt</span><span class="o">=</span>0
         <span class="o">=</span>                       <span class="nv">reflink</span><span class="o">=</span>1
data     <span class="o">=</span>                       <span class="nv">bsize</span><span class="o">=</span>4096   <span class="nv">blocks</span><span class="o">=</span>4455424, <span class="nv">imaxpct</span><span class="o">=</span>25
         <span class="o">=</span>                       <span class="nv">sunit</span><span class="o">=</span>0      <span class="nv">swidth</span><span class="o">=</span>0 blks
naming   <span class="o">=</span>version 2              <span class="nv">bsize</span><span class="o">=</span>4096   ascii-ci<span class="o">=</span>0, <span class="nv">ftype</span><span class="o">=</span>1
log      <span class="o">=</span>internal log           <span class="nv">bsize</span><span class="o">=</span>4096   <span class="nv">blocks</span><span class="o">=</span>2560, <span class="nv">version</span><span class="o">=</span>2
         <span class="o">=</span>                       <span class="nv">sectsz</span><span class="o">=</span>512   <span class="nv">sunit</span><span class="o">=</span>0 blks, lazy-count<span class="o">=</span>1
realtime <span class="o">=</span>none                   <span class="nv">extsz</span><span class="o">=</span>4096   <span class="nv">blocks</span><span class="o">=</span>0, <span class="nv">rtextents</span><span class="o">=</span>0
data blocks changed from 4455424 to 4717568
<span class="o">[</span>root@rhel8 1gig_lv]#
</code></pre>
</div>
<p>Since there was free space in the volume group, we were able to extend the logical volume by 1G. Even if the LV is bigger, we still need to tell the file system that it has more room. Otherwise, we wont be able to reference this new space. So we called xfs_growfs, it is a bit unintuitive that you call it on the mount point, rather than the LV, but it is what it is.<br />
 </p>

<h2 id="conclusion">Conclusion</h2>
<div class="language-bash highlighter-rouge"><pre class="highlight"><code><span class="o">[</span>root@rhel8 1gig_lv]# vgs
  VG         <span class="c">#PV #LV #SN Attr   VSize  VFree</span>
  rhel_rhel8   2   3   0 wz--n- 38.99g &lt;18.00g
<span class="o">[</span>root@rhel8 1gig_lv]# lvs
  LV      VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  1gig_lv rhel_rhel8 -wi-ao----   1.00g
  root    rhel_rhel8 -wi-ao---- &lt;18.00g
  swap    rhel_rhel8 -wi-ao----   2.00g
<span class="o">[</span>root@rhel8 1gig_lv]# pvs
  PV         VG         Fmt  Attr PSize   PFree
  /dev/sda2  rhel_rhel8 lvm2 a--  &lt;19.00g      0
  /dev/sdb1  rhel_rhel8 lvm2 a--  &lt;20.00g &lt;18.00g
<span class="o">[</span>root@rhel8 1gig_lv]# vgs
  VG         <span class="c">#PV #LV #SN Attr   VSize  VFree</span>
  rhel_rhel8   2   3   0 wz--n- 38.99g &lt;18.00g
<span class="o">[</span>root@rhel8 1gig_lv]# lvs
  LV      VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  1gig_lv rhel_rhel8 -wi-ao----   1.00g
  root    rhel_rhel8 -wi-ao---- &lt;18.00g
  swap    rhel_rhel8 -wi-ao----   2.00g
<span class="o">[</span>root@rhel8 1gig_lv]#
</code></pre>
</div>

<p>Here is where we landed. We have assigned out 2G in total. One to a new LV, and another to extend the current root LV. The biggest thing to note here is your file system, and your block devices are handled in separate commands. You have to make sure your file system gets created on new LVs, and grown/extended on existing.<br />
Good luck, hopefully this helps! 
 <br />
 <br />
 <br />
 <br />
 </p>

<script type="text/javascript">
amzn_assoc_placement = "adunit0";
amzn_assoc_search_bar = "true";
amzn_assoc_tracking_id = "jayamafil-20";
amzn_assoc_search_bar_position = "bottom";
amzn_assoc_ad_mode = "search";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_title = "Interested in more information?";
amzn_assoc_default_search_phrase = "redhat enterprise linux";
amzn_assoc_default_category = "All";
amzn_assoc_linkid = "ea12ba787f594414ac31e72e3f5d5b68";
</script>

<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script>

</div>
    <hr />
    <div class="share-page">
    Share this on &rarr;
 <a href="https://twitter.com/share" class="twitter-share-button" data-via="\#">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>

<!-- Facebook -->
<div class="fb-share-button" data-href="/linux/2019/10/09/rhel8-adding-a-drive-to-lvm.html" data-layout="button_count" style="position: relative; top: -7px; right: 3px;"></div>
</div>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

</article>
<hr />


    
    
        
            
                
                <div class="panel-body">
                <h4>Related Posts</h4>
                <ul>
                
                <li class="relatedPost">
                    <a href="/linux/2019/11/01/minimal-dpkg.html">The simplest dpkg you will ever build</a>
                    
                        <small>(Categories: <a href="/category/linux.html">linux</a>)</small>
                    
                </li>
                
                
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
                
                <li class="relatedPost">
                    <a href="/linux/2019/10/01/centos8-live-kernel-patching.html">Centos 8: live updating the kernel using kpatch</a>
                    
                        <small>(Categories: <a href="/category/linux.html">linux</a>)</small>
                    
                </li>
                
                
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
                
                <li class="relatedPost">
                    <a href="/linux/2019/05/29/image-builder.html">Image Builder (composer-cli) in Red Hat Enterprise Linux 8 (RHEL8)</a>
                    
                        <small>(Categories: <a href="/category/linux.html">linux</a>)</small>
                    
                </li>
                
                
            
        
    

    
    
        
            
                
                <li class="relatedPost">
                    <a href="/linux/2019/03/15/building-encrypted-syslog-ng.html">Building Syslog-NG with TLS/SSL support on CentOS6</a>
                    
                        <small>(Categories: <a href="/category/linux.html">linux</a>)</small>
                    
                </li>
                
                
            
        
    

    
    
        
            
                
                <li class="relatedPost">
                    <a href="/linux/2019/03/03/chef-extending-ohai.html">Chef: Extending Ohai to include custom data</a>
                    
                        <small>(Categories: <a href="/category/linux.html">linux</a>)</small>
                    
                </li>
                
                
            
        
    

    
    
        
            
        
    

    
    
        
            
                
                <li class="relatedPost">
                    <a href="/linux/2019/02/05/docker-basics.html">Docker: Basics</a>
                    
                        <small>(Categories: <a href="/category/linux.html">linux</a>)</small>
                    
                </li>
                
                
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    

    
    
        
            
        
    


    </ul>
    </div>


<div class="PageNavigation">
  
    <a class="prev pull-left" href="/linux/2019/10/01/centos8-live-kernel-patching.html">&laquo; Centos 8: live updating the kernel using kpatch</a>
  
  
    <a class="next pull-right" href="/mssql/2019/10/14/mssql-new-dag-over-existing-aag.html">Distributed Availability Groups: Creating a new DAG over an exisiting Availability Group &raquo;</a>
  
</div>


<div class="disqus-comments">
    <div id="disqus_thread"></div>
    <script type="text/javascript">
        /* <![CDATA[ */

        var disqus_shortname = "fazey";
        var disqus_identifier = "_RHEL8: Adding a second drive to LVM";
        var disqus_title = "RHEL8: Adding a second drive to LVM";

        /* * * DON'T EDIT BELOW THIS LINE * * */
        (function() {
            var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
            dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
        })();
    /* ]]> */
    </script>
</div>
</div>

          <div class="row">
            <div class="col-md-12 col-xs-12 footer">
              <footer>
</footer>
<div align="center">
  <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
  <ins class="adsbygoogle"
    style="display:block"
    data-ad-client="ca-pub-0000000000000000"
    data-ad-slot="0000000000"
    data-ad-format="auto"></ins>
  <script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>

            </div>
          </div>
        </div> <!-- end /.col-md-9 -->
      </div> <!-- end /.row -->
    </div>

    
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
<script src="https://code.jquery.com/jquery-migrate-1.2.1.min.js"></script>
<script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.6/js/bootstrap.min.js"></script>

<script src="/static/js/super-search.js"></script>

<script src="/static/js/thickbox-compressed.js"></script>
<script src="/static/js/material.min.js"></script>
<script src="/static/js/main.js"></script>
<script src="/static/js/projects.js"></script>

    <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-101964036-1', 'auto');
  ga('send', 'pageview');

</script>
  </body>
</html>
